Bad Request : Parameter weightInGrams not found (For Garmin)?

jetritjetrit Member Posts: 9

Hi,
Im new here, so please feel free to correct me if I ask in the wrong place.

ok so i have a garmin scale and connected conrad to connect.garmin.com, but in projects any time i push test i get Bad Request parameter XXX not found. the weight is not available any place. but data like steps are shown in Dashboard but also fails in projects.

so where did the chain fall off. any input or ideas are welcome

thanks.

Answers

  • ChristianChristian admin Administrator, Moderator Posts: 1,687 admin

    Welcome @jetrit! Since the Garmin Scale is not yet listed as a supported device, we cannot fully guarantee proper functioning. However, please consider the following advice. 1) You always need to sync your Garmin App in order to send your latest data to Conrad Connect. 2) The test button may just not work for certain parameters. Please try to set up and run a simple Conrad Connect project based on parameters that actually work and let us know what happened, thanks.

  • LebauskeeLebauskee Member Posts: 18

    If you see data on the dashboard means it's working and there is data for this device which could be used in projects.

    So as mentioned before just create a project and see if it works

  • jetritjetrit Member Posts: 9

    @Christian said:
    Welcome @jetrit! Since the Garmin Scale is not yet listed as a supported device, we cannot fully guarantee proper functioning. However, please consider the following advice. 1) You always need to sync your Garmin App in order to send your latest data to Conrad Connect. 2) The test button may just not work for certain parameters. Please try to set up and run a simple Conrad Connect project based on parameters that actually work and let us know what happened, thanks.

    ok, so lets start with one that works. The steps count i visible on the Dashboard so the data is there.
    I based my test on number 3 in the most popular public projects called "send SMS if i walk more than 4000 steps"
    my step count in garmin connect was 1687 so i changed the upper bound to 1700 and updated the email address and subject. and saved the project.
    and got an success email that i had walked the 1700 (i had not)
    i opened the project again and updated the email to say:

    "You made it {{User_Steps_1.parameter}}

    state {{User_Steps_1.state}}"

    i saved, and again a success email with the text:

    "You made it state"

    I got some coffee and synced garmin connect again so that i now passed the 1700 steps, but no mail.

    i speculate that the garmin sensor failed, and that triggered the mail, but there was not data.

    what further can i do to debug?

    I hope you can help.

    /Jetrit

  • ChristianChristian admin Administrator, Moderator Posts: 1,687 admin
    edited September 2018

    Hi @jetrit, would you mind publishing your project so we could examine it? Private data such as your email address will remain private. Thanks.

  • jetritjetrit Member Posts: 9

    ok done, its called "test for Christian"

  • ChristianChristian admin Administrator, Moderator Posts: 1,687 admin

    Thank you @jetrit, the logic of the project itself looks right. How about you give me more time so I could check whether there is a chance to get the project based on this particular (not yet supported) device running?

  • jetritjetrit Member Posts: 9

    Hi again,

    The garmin index scale might not be supported, but now we are talking about steps, and those are coming from my watch (garmin fenix 5) that might not be supported either. but i just waned to be clear that the steps are not coming from the weight.

    lets also be clear that you are not interacting with my device, but with the garmin health API, the health api only provide information like Bone_Mass, Body_fat, Muscle_mass, Body_water if there is a garmin index scale, so you have 4 sensores that depends on a product you do not support.

    but for now lets focus on the steps, we see that the steps are on my Dashboard, you have validated the project, so somewhere between the dashboard and the project something is off.

    I hope we can find the bottom of this, let me know if there is anything more you need from me?

    /Jens

  • ChristianChristian admin Administrator, Moderator Posts: 1,687 admin

    Sure, I'll get back to you here the next days.

  • jetritjetrit Member Posts: 9

    Sounds good

    Thanks

    /Jens

  • ChristianChristian admin Administrator, Moderator Posts: 1,687 admin
    edited September 2018

    Hi Jens, yes, we are connected to the Garmin API only. As for troubleshooting, could you please setup a new project as seen in the screenshot. That is, please define a certain time period (e.g. between 8 and 9 pm) and let Garmin trigger a message or email in all cases (above, below, in range --> you can select them all one after another as seen on the screenshot). Please let us know what happens.

  • jetritjetrit Member Posts: 9

    Hi Again,
    sorry for the delay, i was off-line.

    I have created the requested project (i redid the project that i shared, so you can see it there it is now named "as per request"

    and it should trigger in 7 minutes

    lets see what happens

  • jetritjetrit Member Posts: 9

    hmm no success, or i got the message "You made" and nothing more, i hope you got something from that.

  • ChristianChristian admin Administrator, Moderator Posts: 1,687 admin

    Hi @jetrit, thanks for your efforts. We have now requested our development team to look into this.

  • jetritjetrit Member Posts: 9

    Hi @Christian
    is there any news on this?

    /Jens

  • ChristianChristian admin Administrator, Moderator Posts: 1,687 admin

    Hallo Jens, nein, aber ich hake gern noch mal nach.

  • jetritjetrit Member Posts: 9

    Hi Again Christian,
    What did they say when you asked them back in October?

  • ChristianChristian admin Administrator, Moderator Posts: 1,687 admin

    Hi @Jetrit, yes the Technical team reported back stating that they could not identify any problem. Could you please check this project which is working? I would recommend removing the BetweenHours element to begin with.

  • RolliRolli Member Posts: 5

    Hello all, I have the same problem. I use a Garmin vivoactive HR watch, connected to Garmin Connect. My Garmin account is connected to Conrad connect. But no data from the Garmin dashboard nor the vivoctive HR can obtained from Conrad connect. I tried all your tips from this threat with no success. I always get the message "Bad Request : Parameter steps not found" or similar, when I press the Test button.There is no difference with other sensors i.e. "Bad Request : Parameter heartRate not found".
    Any ideas?

  • ChristianChristian admin Administrator, Moderator Posts: 1,687 admin

    Hi @Rolli, will report this our service team.

  • RolliRolli Member Posts: 5
    Ok, would be nice to hear from you. =)
Sign In or Register to comment.