Homematic IP actuator works intermittently

I have a couple of projects that trigger IFTTT and email events every hour when a room temperature is less than the thermostat setting. The Homematic schedule increases the thermostat setting first thing in the morning for one of the rooms and the events are triggered correctly once. However, after that the project doen't trigger further events hourly, and if the conditions are met for the other room the other project won't trigger events either. If I open one of the projects and save it without making any changes, both projects then work correctly, triggering the events every hour if appropriate.

It seems the Homematic IP service needs to be woken up each day. What can I do to fix this? I'm hoping someone can suggest something as I'd really like to set up more projects in Conrad Connect.

Comments

  • ChristianChristian Administrator, Moderator Posts: 1,294 admin

    Hi @Dave_S, can I kindly ask you to provide a screenshot of the respective Conrad Connect project. I am confident that we can sort this out.

  • ChristianChristian Administrator, Moderator Posts: 1,294 admin

    Also, when you say

    The Homematic schedule increases the thermostat setting first thing in the morning

    do you mean that Conrad Connect is already involved in this?

  • Dave_SDave_S Member Posts: 9

    Christian, thanks for getting back to me. I've attached a screenshot.

    The Homematic schedule is set in the Homematic IP app and changes the thermostat setting to 22 degrees at 6.30am. This causes the IFTTT and email actuators to work. That room usually heats up within an hour and so no further events are expected to get fired until later because the Homematic schedule turns the thermostat setting down to 17 degrees after 3 hours.

    There is a similar project for another room. I manually change the thermostat setting to 21 degrees in that room later and that doesn't work the actuators. Also, if I change the thermostat setting in the room shown in the screenshot to 22, again the actuators don't work. But if I open any one of the projects and save it without making any changes, the expected actuators work immediately if the conditions are correct (ie. thermostat 21 or 22 and temperature less than 20.5) and they then continue working properly for the rest of the day.

    I hope I've explained that OK but just ask if you've any other questions.

  • ChristianChristian Administrator, Moderator Posts: 1,294 admin

    Hi @Dave_S, thanks for the detailed update. I'll need to talk to my Tech Support Team on Tuesday. Let me please just ask if the screenshot reflects both rooms or just one room? Or in other words, how many HmIP devices are reflected in your project, two or more?

  • Dave_SDave_S Member Posts: 9
    Hi Christian, the screenshot is just for one room. That room has a Homematic wall thermostat linked to 3 radiator valves - so just one Homematic device.
  • ChristianChristian Administrator, Moderator Posts: 1,294 admin

    Hi @Dave_S, we still need to better understand what you are aiming at. So, you adjust the target temperature manually in the room shown on your screenshot and would like to trigger certain actuators if both is true 1) target temperature within certain range and AND 2) current temperature still below that target. But why do you set this up twice (referring to the upper and lower part on the sensor side).

  • Dave_SDave_S Member Posts: 9
    Hi Christian, the upper two sensors are supposed to detect when the thermostat is set to 21 and the room temperature is below that. The lower two are to detect when the setting is 22.
  • ChristianChristian Administrator, Moderator Posts: 1,294 admin

    Thanks, @Dave_S, but why do you combine these two strings (which reflect the same pyhsical sensors) again logically with OR?

  • Dave_SDave_S Member Posts: 9

    Christian, I was trying to achieve this:

    If (
    ((lounge_target = 21) and (lounge_temp <21))
    or ((lounge_target = 22) and (lounge_temp <22))
    )
    then trigger the IFTTT and email actuators.

    I hope I’ve got the brackets correct in that.

    I couldn’t find a simpler way of just triggering when the room temperature is less than the thermostat setting without explicitly specifying the temperatures. Also, the project designer wouldn’t let me have more than one link to an actuator so I used the OR gate.

  • ChristianChristian Administrator, Moderator Posts: 1,294 admin

    Thanks @Dave_S, our Tech support team wonders whether this is due to loosing connection to Homematic IP as they have discovered similar behavior in the past. Could you please contact them directly at [email protected] along with your login credentials as well as a link to this thread?

  • Dave_SDave_S Member Posts: 9

    Thanks Christian. Will do.

  • Dave_SDave_S Member Posts: 9

    Hi Christian, good news! For the last 2 days all has worked as expected. Homematice IP servers were down on Tuesday morning for maintenance - don’t know if that had anything to with it, but the projects have been working well since then.

    Thanks for looking into this and for your help.

  • ChristianChristian Administrator, Moderator Posts: 1,294 admin

    Hi @Dave_S, well, that's good news. Yes, they had a server maintenance this week. Can you please update me once more in a week or so? What did you actually want to achieve with this rather sophisticated project setup?

  • Dave_SDave_S Member Posts: 9

    Christian, yes, I’ll let you know how it goes.

    The IFTTT actuators use Hive to switch on the central heating boiler. The emails are just to let me know if the sensors have triggered the action - originally I didn’t have the IFTTT settings correct, so I could probably do without them now. It would be more straightforward if there was a Homematic IP sensor in Conrad Connect that was simply TRUE if the room temperature was less than the thermostat setting.

  • ChristianChristian Administrator, Moderator Posts: 1,294 admin

    Hi @Dave_S, thanks. Agree, in your case such a sensor would make sense.

  • Dave_SDave_S Member Posts: 9

    Hi Christian, just getting back to you to let you know that the projects have been working and triggering as expected for over a week now. I’m very pleased with the setup. Thanks for all your help.

Sign In or Register to comment.