Tado + HmIP funktioniert unzuverlässig. ☹️ Hilfe

Hallo Community, hallo Christian,
helft mir bitte die Probleme mit meinem Projekt zu klären. Ich benutze CC zweiten Winter, um tado Thermostate mit Homematic IP Fensterkontakten zu verkoppeln, da ich mit tado Fensteroffenerkennung unzufrieden bin. Wenn es letzten Winter mehr oder weniger funktioniert hat, diesen Winter läuft alles ganz instabil, unzuverlässig. Ich habe mein Projekt umbearbeitet, getestet und es hat funktioniert. Ich habe es veröffentlicht. Aber es läuft doch instabil. Zum Beispiel gerade heute, um halb elf, haben wir gelüftet und das Projekt hat wunderbar alle Schritte abgearbeitet: Fenster auf - t auf 7°; Fenster zu - t auf 9° + Verzögerung; Verzögerung zu Ende - t auf 21°. Aber schon nachmittag gegen fünf Uhr habe ich mehrmals das Fenster auf und zu gemacht und konnte dabei keinerlei Reaktionen an dem Heizkörper feststellen, ob mein Projekt deaktiviert wäre. HmIP-app hat aber jedes öffnen und schließen registriert. Oder was noch sehr oft passiert, dass der letzte Schritt ausfällt - nach der Verzögerung bleibt der Heizkörper bei 9° hängen. Ich bin total verzweifelt und bitte um die Hilfe.
Danke.

Tagged:

Comments

  • ChristianChristian Administrator, Moderator Posts: 2,101 admin
    edited February 2

    Hallo @W1Heinz, das Projekt hat also nie richtig funktioniert, korrekt? Ich poste mal einen Screenshot des Projekts zur besseren Veranschaulichung. Der Sensor im Projekt ganz oben links erfasst die Zieltemperatur des Tado-Thermostaten?

    Die Kontaktsensoren liefern nur ein kurzes Triggersignal, weshalb eine logische Verknüpfung nicht in allen Fällen möglich ist. Ich würde erst mal nur den Zieltemperatursensor sowie den Kontaktsensor über ein AND-Gatter verknüpfen und dahinter den Telegram-Nachrichten-Aktor klemmen, um das Verhalten zu verstehen. Ferner würde ich immer so einfach wie möglich denken: Wenn OFFEN, dann Zieltemperatur herabsetzen und umgekehrt.

  • W1HeinzW1Heinz Member Posts: 4

    Hi @Christian

    Hallo @W1Heinz, das Projekt hat also nie richtig funktioniert, korrekt?

    Nein. Das Problem ist, dass das Projekt Mal richtig funktioniert, Mal teilweise, Mal gar nicht. Wie ich schon geschrieben habe, am meisten gibt es Probleme mit der Wiederherstellung der Temperatur nach der Verzögerung, ob die Verzögerung ins leere geht. Aber neulich hat das Projekt gar nicht auf das Öffnen des Fensters reagiert und das ist das erste, was es machen sollte. Ich habe gestern tado und HmIP vom CC getrennt und wieder angelernt. Hat nicht wirklich geholfen. Heute früh ist der Thermostat nach Ablauf der Verzögerung wieder bei 9° geblieben.

    Der Sensor im Projekt ganz oben links erfasst die Zieltemperatur des Tado-Thermostaten?

    Ja. Und ihn brauche ich um 1. nach der Verzögerung zu erkennen ob das Fenster immer noch zu ist oder wurde zwischenzeitlich wieder geöffnet 2. um zu verhindern, dass das Projekt im Sommer die Temperatur am Heizkörper dreht. Am Sensor ist die Spanne zwischen 6 und 8 Grad eingestellt. Im Sommer ist der Thermostat aus - gleich Zieltemperatur 5°. Und in meinem Projekt soll die Zieltemperatur bei jedem Schritt höher sein. Die Logik ist folgende: ist beim öffnen des Fensters Zieltemperatur höher als 8°, wird sie auf 7° runtergestuft; beim schließen des Fensters wird die Temperatur auf 9° gesetzt, wenn sie gleich oder höher als 6° ist; und nach der Verzögerung wird die Temperatur erst dann auf vollständiges Heizen gesetzt (21° am Tag, 18° nachts - zwischen Stunden Sensor) wenn sie höher als 8° ist (denn wenn zwischenzeitlich das Fenster wieder aufgemacht wurde, dann wird die Temperatur wieder auf 7° gesetzt).

    Die Kontaktsensoren liefern nur ein kurzes Triggersignal, weshalb eine logische Verknüpfung nicht in allen Fällen möglich ist.

    Das ist mir bekannt. Kontaktsensor wird beim mir nur zum Anstoß verwendet. Und auch diese Problematik ist mir bekannt, deswegen steht kein Logikgatter vor der Verzögerung. Wie gesagt, ich habe das Projekt überarbeitet, ich habe zwischen Stunden Sensor hinzugefügt. Früher hat es mir die Temperatur immer auf 21° wiederhergestellt. Wenn ich aber spät abends durchlüfte, dann will ich die Spartemperatur zurück bekommen haben. Und seit dem habe ich öfters Probleme mit dem Projekt, als im letzten Winter.

  • ChristianChristian Administrator, Moderator Posts: 2,101 admin

    Hallo @W1Heinz, gibt es hier noch Probleme?

  • W1HeinzW1Heinz Member Posts: 4

    Hi @Christian, was kannst du mir zu den zwei letzten UNDLogikgatter sagen, die nach der Verzögerung in Einsatz kommen. Wie ich geschrieben habe, bei denen habe ich öfters Probleme. Gerade heute nach dem lüften habe ich meine gewünschten 21° zurück bekommen, aber gestern Abend hat es wieder gehackt - Thermostat ist bei 9° hängengeblieben. Warum spinnen die? Es ist irgendwie 50/50 Situation - Mal funktioniert, Mal nicht. In diesem Falle spielt Fensterkontakt keine Rolle.

  • ChristianChristian Administrator, Moderator Posts: 2,101 admin

    Hallo @W1Heinz, das Verhalten komplexer Schaltungen können wir leider nicht ins bis in letzte Detail vorhersagen. Meine Tipps: Vereinfachen, ggf. das Verzögerungselement ganz herausnehmen sowie mit Nachrichtenaktoren arbeiten, um die Fehlerquelle einzugrenzen. Oder teste doch mal, ob du jenen Strang, der zum Einschalten dient, nicht doppelt legst.

  • W1HeinzW1Heinz Member Posts: 4

    Ok, danke, ich experimentiere weiter =)

Sign In or Register to comment.