IFTTT Trigger erkannt aber Recipe nicht ausgeführt

MounirMounir Member Posts: 18
edited March 20 in Tipps zum Troubleshooting

Ich habe immer wieder das Problem, dass IFTTT Trigger in ConradConnect zwar erkannt werden , die zugehörigen Recipes aber nicht ausgeführt werden.
Im Dashboard sieht man es ebenfalls. Wenn ich den Trigger nochmals ausführe geht es dann meist .
Hat jemand eine Idee, woran das liegt ? Der Trigger kommt ja korrekt an. Warum führt ConradConnect so unzuverlässig aus?

Im Beispiel sieht man den KOMMEN Trigger, der erst beim 2. Versuch das Recipe starten konnte :(

Comments

  • ChristianChristian Administrator, Moderator Posts: 1,415 admin

    Hallo @Mounir, kannst du bitte mal an den IFTTT-Maker Channel einen Nachrichten-Aktor klemmen, z.B. Pushover? Dann können wir vergleichen und das Problem im besten Fall eingrenzen.

  • MounirMounir Member Posts: 18

    Ich habe Twitter DM direkt eingebunden.
    Sowohl die Nachricht als auch die Funkionen in Homematic IP funktinierten heute erst beim 5. Versuch

  • ChristianChristian Administrator, Moderator Posts: 1,415 admin

    Hallo @Mounir, danke für die genauen Beobachtungen. Ich bitte die Kollegen, dies am Montag noch einmal zu prüfen.

  • ChristianChristian Administrator, Moderator Posts: 1,415 admin

    Hallo @Mounir, könntest du bitte einen Projekt-Screenshot hinzufügen? Danke.

  • MounirMounir Member Posts: 18
    edited March 25

    Na klar kein Problem.
    Das sieht wie folgt aus

    Heute hat es auch etliche Versuche gebraucht bis das Projekt ausgelöst wurde.

    Es ging diesmal dann erst nachdem ich ins Projekt bin ohne Änderungen und hab dann nochmal speichern geklickt.
    Dann löste der Trigger aus

    Komischerweise war der Recipe Log komplett leer im Dashboard, obwohl es heute morgen ausgelöst hatte.

  • ChristianChristian Administrator, Moderator Posts: 1,415 admin

    Hallo @Mounir, ich würde stark vermuten, dass nicht die IFTTT-Maker-Anbindung das Problem verursacht, sondern die logische Verknüpfung von Sensoren, die keine zeitlich konstanten Signale senden. Reagiert denn der Twitter DM immer? Warum regelst du nicht global auf Automatik vs. Eco? Welches Teilprojekt sehen wir? Im Büro ankommen?

  • MounirMounir Member Posts: 18
    edited March 25
    Das dachte ich auch zuerst.
    Aber durch dein Tipp mit Twitter kann ich das ausschließen, dann Twitter geht auch nur wenn das Projekt arbeitet. Also hier auch nach dem x-ten Mal.

    Das Projekt ist komplett und heißt "beim Heimkommen wenn Temp < x Heizung an"

    Die Zieltemperatur im Büro wird lediglich genutzt um Festzustellen ob die Heizung überhaupt in Betrieb ist.

    Die Anbindung des IFTTT Maker kann es ja eigentlich auch nicht sein, oder ist die unabhängig von den IFTTT Events im Dashboard? Da kommt es ja an , bzw. IFTTT übermittelt zumindest korrekt.
  • ChristianChristian Administrator, Moderator Posts: 1,415 admin

    Hallo @Mounir, danke, kurz ein weiterer Gedanke auf dem Weg zur Lösung: Kann es sein, dass der Location Detektor unzuverlässig arbeitet?

  • MounirMounir Member Posts: 18
    edited March 26

    Ich denke nicht, woher käme sonst der Eintrag im IFTTT Event auf dem Dashboard?

  • ChristianChristian Administrator, Moderator Posts: 1,415 admin

    Stimmt. Ich spreche nachher noch einmal mit den Kollegen und melde mich im Laufe der Tage.

  • MounirMounir Member Posts: 18

    @Christian :
    Heute könnte Deine Vermutung mit der Problematik bei der logischen Verknüpfung und den Signalen zutreffen.
    Das kommen wurde ausgelöst und in beiden Fällen Twitter DM gesendet. Die HmIP wurde aber nur im 2. Versich angesprochen und die Heizung eingeschaltet.

    Diese konstellation ist heute aber erstmalig aufgetreten . Zuvor war auch keine Twitter DM gesendet worden.

  • ChristianChristian Administrator, Moderator Posts: 1,415 admin

    Hallo @Mounir, habe dieses Projekt angelegt. Muss morgen getestet werden. Dann kann es uns vielleicht helfen, der Frage genauer auf den Grund zu gehen.

  • MounirMounir Member Posts: 18

    Sehr gut!
    Evtl. klemmt da ja wirklich was beim Auslösen, denn der IFTTT Trigger kommt jedesmal und bisher absolut verlässlich (lt. Dashboard)

    Ich sag schonmal Danke vorab!

  • MounirMounir Member Posts: 18

    Ich habe das jetzt eine Weile beobachtet und mehrere TwitterDM Aktoren eingebaut zur Prüfung.
    Wie mir scheint ist die Anbindung an HomeMaticIP nicht zuverlässig.

    Ich habe inzwischen mehrfach die Messages erhalten, aber der Part in HmIP wurde nicht geschaltet.

    Im Beispiel heute und auch vor 2 und vor 5 Tagen folgendes:
    Der Obere Bereich (Vollschutz an) hat immer funktioniert.

    Die Message für den unteren Bereich wurde ebenfalls ausgelöst, ABER der ECO Modus der Heizung NICHT geschaltet.

    Manuelles (manchmal mehrfach) Triggern der Aktion sorgt dann dafür, dass es doch noch klappt.

    Ich hatte ursprünglich Combo Boxen mit der Abfrage der Stati von HmIP Geräten drin und dachte hier kommen nicht immer Signale an.
    Aber leider ist es beim Senden an den Aktor ähnlich.

    Gibt es da Probleme bei der Anbindung an HmIP?
    Oder muss ein Delay zwischen den Befehlen an HmIP eingebaut werden?

Sign In or Register to comment.